$re = '/-----Message d\'origine-----.*(?:\r?\n(?!\r?\n).*)*\s*/m';
$str = 'Something above
-----Message d\'origine-----
De : Myself <myself@himself.com>
Envoyé : vendredi 8 mars 2019 14:30
À : Someone <someone@himself.com>
Cc : AnotherGuy <another@himself.com>
Objet : My bad I forgot how to do it
Hi,
blabla';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;