# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-----Message d'origine-----.*(?:\r?\n(?!\r?\n).*)*\s*"
test_str = ("Something above\n\n"
"-----Message d'origine-----\n"
"De : Myself <myself@himself.com>\n"
"Envoyé : vendredi 8 mars 2019 14:30\n"
"À : Someone <someone@himself.com>\n"
"Cc : AnotherGuy <another@himself.com>\n"
"Objet : My bad I forgot how to do it\n\n"
"Hi,\n\n"
"blabla")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.