$re = '#якорь|\[special\].*?\[/special\](*SKIP)(*F)#s';
$str = 'К примеру есть какой то текст:
"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст"';
$subst = "TXT";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;