re = /\bPresident\W+(?:\w+\W+){1,6}?Trump\b/
str = 'President word1 word2 word3 word4 word5 word6 Trump'
# Print the match result
str.match(re) do |match|
puts match.to_s
end