use strict;
my $str = ' a01a b02 c03 e dfdfd abcdef=2 b=3 e=4 c="a b" aaa=2f f="asdf 12af"';
my $regex = qr/(?<![\"=\w])(?:[^\W_]+)(?![\"=\w])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}