import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^|[a-zA-z]+\\w*+[\\/(]*+[0-9][0-9][)]*|^";
final String string = "gl23455/10\n"
+ "fhgg666(01)\n"
+ "BGL25MON8/04\n"
+ "0752200036(00)\n"
+ "SGI55M04EU/70\n"
+ "KSK38422FF/01\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}