#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[a-z])(?=.*\d)[A-Za-z\d!$%@#£€*?&]{8,}$"
Local $sString = "A88888jf" & @CRLF & _
"Aa88888jf" & @CRLF & _
"Aa888jf" & @CRLF & _
"AAAAAAAAAAA" & @CRLF & _
"aaaaaaaaaaaaaa" & @CRLF & _
"2222222222222222" & @CRLF & _
"1sAdfe44" & @CRLF & _
"$#fd#######" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")