import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)[A-Za-z\\d!$%@#£€*?&]{8,}$";
final String string = "A88888jf\n"
+ "Aa88888jf\n"
+ "Aa888jf\n"
+ "AAAAAAAAAAA\n"
+ "aaaaaaaaaaaaaa\n"
+ "2222222222222222\n"
+ "1sAdfe44\n"
+ "$#fd#######\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}