#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^aaa_"
Local $sString = "aaa_house" & @CRLF & _
"aaa_car" & @CRLF & _
"aaa_table" & @CRLF & _
"aaa_love" & @CRLF & _
"aaa_hate" & @CRLF & _
"aaa_life"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)