const regex = new RegExp('^aaa_', 'gm')
const str = `aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);