use strict;
my $str = 'aaa_house
aaa_car
aaa_table
aaa_love
aaa_hate
aaa_life';
my $regex = qr/^aaa_/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";