#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<Workorder>\d{4}),(?<ExternalUnit>\d{7}),(?<Pieces>\d),(?<SubItem>\d+$)"
Local $sString = "6432,6432305,1,6432305038" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")