using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<Workorder>\d{4}),(?<ExternalUnit>\d{7}),(?<Pieces>\d),(?<SubItem>\d+$)";
string input = @"6432,6432305,1,6432305038
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}