#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^config\s.*?(?=(?:\r?\n)+(?:config\s|\Z))"
Local $sString = "config vdom" & @CRLF & _
"edit root" & @CRLF & _
"next" & @CRLF & _
"edit test" & @CRLF & _
"next" & @CRLF & _
"edit test2" & @CRLF & _
"next" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"config global" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"config vdom" & @CRLF & _
"edit root" & @CRLF & _
"config system" & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"config ..." & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"......" & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"config vdom" & @CRLF & _
"edit test" & @CRLF & _
"config system" & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"config ..." & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"......" & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"config vdom" & @CRLF & _
"edit test2" & @CRLF & _
"config system" & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"config ..." & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"end" & @CRLF & _
"end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")