re = /^TCGA-[A-Z0-9]+-([A-Z0-9]+)$/m
str = 'TCGA-A2-A0T2
TCGA-A2-A0CM
TCGA-BH-A18V
TCGA-BH-A18Q
TCGA-BH-A0E0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end