using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^{map:\h+geo=""(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)""[^}]+}";
string input = @"{map: geo=""20.471884,-157.505,6"" p=""Hawaii""}
{map: geo=""-157.505,6,-20.471884,5"" p=""Hawaii""}
{map: geo=""-157.505,6,20.471884"" p=""Hawaii""}
{map: geo=""157,11111"" p=""Hawaii""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}