// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^{map:\h+geo="(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)"[^}]+}"#).unwrap();
let string = "{map: geo=\"20.471884,-157.505,6\" p=\"Hawaii\"}
{map: geo=\"-157.505,6,-20.471884,5\" p=\"Hawaii\"}
{map: geo=\"-157.505,6,20.471884\" p=\"Hawaii\"}
{map: geo=\"157,11111\" p=\"Hawaii\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}