import Foundation
let pattern = #"^{map:\h+geo="(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)"[^}]+}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{map: geo="20.471884,-157.505,6" p="Hawaii"}
{map: geo="-157.505,6,-20.471884,5" p="Hawaii"}
{map: geo="-157.505,6,20.471884" p="Hawaii"}
{map: geo="157,11111" p="Hawaii"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)