const regex = /(\[To:\d+\]|\[reply:\d+\]|\[quote:\d+\]|\[返信:\d+\]|\[引用:\d+\]).+(さん)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[To:\\d+\\]|\\[reply:\\d+\\]|\\[quote:\\d+\\]|\\[返信:\\d+\\]|\\[引用:\\d+\\]).+(さん)', 'gm')
const str = `
[To:1183]user1 - business 1さん[To:1186]user 1 - supplier 1さん
[To:1191]user3 - business1さん
[To:1224]user - client 1 (business1)さん`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}