#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][1-9]|3[0-1])\s(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])"
Local $sString = "" & @CRLF & _
"2018-12-06 17:50:03" & @CRLF & _
"2019-09-19 08:44:42" & @CRLF & _
"2019-08-12 21:16:56" & @CRLF & _
"2019-04-25 15:05:29" & @CRLF & _
"2018-01-04 20:01:04" & @CRLF & _
"2019-07-24 08:01:00" & @CRLF & _
"2019-06-24 21:51:26" & @CRLF & _
"2016-12-22 19:19:14" & @CRLF & _
"2016-12-30 19:19:14" & @CRLF & _
"2016-12-31 19:19:14" & @CRLF & _
"2016-12-31 19:59:59" & @CRLF & _
"2016-12-31 19:00:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")