use strict;
my $str = '
2018-12-06 17:50:03
2019-09-19 08:44:42
2019-08-12 21:16:56
2019-04-25 15:05:29
2018-01-04 20:01:04
2019-07-24 08:01:00
2019-06-24 21:51:26
2016-12-22 19:19:14
2016-12-30 19:19:14
2016-12-31 19:19:14
2016-12-31 19:59:59
2016-12-31 19:00:00';
my $regex = qr/[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][1-9]|3[0-1])\s(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}