import Foundation
let pattern = #"[0-9]{4}-(0[1-9]|1[0-2])-(0[1-9]|[1-2][1-9]|3[0-1])\s(0[0-9]|1[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2018-12-06 17:50:03
2019-09-19 08:44:42
2019-08-12 21:16:56
2019-04-25 15:05:29
2018-01-04 20:01:04
2019-07-24 08:01:00
2019-06-24 21:51:26
2016-12-22 19:19:14
2016-12-30 19:19:14
2016-12-31 19:19:14
2016-12-31 19:59:59
2016-12-31 19:00:00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)