#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
" (?=(?:(?![mM]{2}).)*[mM]{2}(?:(?![mM]{2}).)*$)" & @CRLF & _
" (?=(?:(?![dD]{2}).)*[dD]{2}(?:(?![dD]{2}).)*$)" & @CRLF & _
" (?=(?:(?![yY]{2}(?:[yY]{2})?).)*[yY]{2}(?:[yY]{2})?(?:(?![yY]{2}(?:[yY]{2})?).)*$)" & @CRLF & _
" (?:" & @CRLF & _
" (?:[mM]{2}|[dD]{2}|[yY]{2}(?:[yY]{2})?)" & @CRLF & _
" (?:[_-](?!$))?" & @CRLF & _
" ){3}" & @CRLF & _
"$"
Local $sString = "The expected result is that only combinations such as the following can test true:" & @CRLF & _
"dd-mm-yy" & @CRLF & _
"MM-DD_YYYY" & @CRLF & _
"yyyy_dd-MM" & @CRLF & _
"mmddyy" & @CRLF & _
"YYYYddMM" & @CRLF & _
"" & @CRLF & _
"And not something like:" & @CRLF & _
"ddyyyyymmmmmmmmm" & @CRLF & _
"mmddyymm" & @CRLF & _
"" & @CRLF & _
"ADDITIONAL no-checks:" & @CRLF & _
"mmmmmm" & @CRLF & _
"yyyymmmm" & @CRLF & _
"yydddd" & @CRLF & _
"YYYYddMM-" & @CRLF & _
"ddyyyy" & @CRLF & _
"yyyymm" & @CRLF & _
"yyyydd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")