$re = '/(?<![^ ,\n])
(?|
([23]?)()([MSEURFBDL])(w?)|
([2-5]?)()([mseurfbdl])()|
(?|(2)-([3-5])|(3)-([45]))([mseurfbdl])()
)
([2\']?)
(?![^, \n])/mx';
$str = 'L\' 3l 2-4r\' test 3-2l
2L\',
m\',
2R,
R,
Lw\',
2-3l\',
2-3r,
Rw,
3l\',
M\',
3r,
4l\',
4r,
L,
2L,
2-3u\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);