$re = '/(?<!\d)\d(?!\d)/m';
$str = '"R3g3x"
"J4v4scr1pt"
1nício"
"Fina1"
"Dup10"
abc10xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);