re = /(?<!\d)\d(?!\d)/m
str = '"R3g3x"
"J4v4scr1pt"
1nĂcio"
"Fina1"
"Dup10"
abc10xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end