#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?|^(\d)|\D(\d))(?!\d)"
Local $sString = ""R3g3x"" & @CRLF & _
""J4v4scr1pt"" & @CRLF & _
"1nício"" & @CRLF & _
""Fina1"" & @CRLF & _
""Dup10"" & @CRLF & _
"abc10xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")