$re = '/\b((?:LON|LAT)\d\t)(\s-?\d+(?:\.\d+)?)\b/m';
$str = 'LON1 129.97579956
LAT1 -26.33283424
LON2 130.10830688
LAT2 -26.33283424';
$subst = "$1=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;