$re = '~\[(\w+)(?:\s+[^]]*)?].*?\[/\1](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\S+\.\w+~ms';
$str = 'example@yahoo.com
]example@yahoo.com[
[mail]exmaple@yahoo.com[/mail]
$texts[] = "example@yahoo.com";
$texts[] = "[mail]example@yahoo.com[/mail]";
$texts[] = "[other]example@yahoo.com[/other]";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);