package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([aA-zZ][aA-zZ][aA-zZ])\s*\-\s*([0-9]{1,2})\s*\-\s*([0-9][0-9])`)
var str = `DEC-17-20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}