package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([&$\+,:;=\?@#\s<>\[\]\{\}[\/]|\\\^%])+`)
var str = `this pat#h%•¶%{has}[many]\inv[alid∑¡™/£¢∞§¶•ª{º!“‘?÷@≠«;–˚$∆ß,Ω µc+ha?ra&cters
this-ªº“‘÷≠-is-a-到英语-good-url.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}