import re
regex = re.compile(r"[+·`\-::]*?([\u4e00-\u9fa5]+)[+\-十](\d+([.::]\d){0,2})(%|0/0|0\|0|010)?", flags=re.MULTILINE)
test_str = ("·暴击伤害+21.2%\n"
"·元素精通+11\n"
"暴击率+17.1%\n"
"+攻击力+20\n"
"·防御力+98\n"
"`防御力+21.7%\n"
"`生命值+2147\n"
"-攻击力+15.70/0\n"
"·暴击率+3:9%\n"
"防御力+31:0%\n"
"暴击伤害+46.6010")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")