$re = '/^(\d+\.?)(\d+\.)?(\S+)?$/';
$str = '1.0.0-debug';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);