import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/([a-z]{2})(?:\\/([a-z]{2}_[A-Z]{2}))?)";
final String string = "test.com/en\n"
+ "test.com/en/en_US\n"
+ "test.com/es\n"
+ "test.com/es/es_ES\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}