$re = '/(?:\/([a-z]{2})(?:\/([a-z]{2}_[A-Z]{2}))?)/';
$str = 'test.com/en
test.com/en/en_US
test.com/es
test.com/es/es_ES
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);