$re = '/^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-zøåæäöüß][a-z0-9øåæäöüß]*)*$/im';
$str = 'No-idea,if-is-what,you-want
No-idea,if-is-whatyou-want
No-idea,if-is-whatyou-
No-idea,if-is-whatyou,
asd,1dsa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);