import re
regex = re.compile(r"^[a-zøåæäöüß][a-z0-9øåæäöüß]*(?:[-,][a-zøåæäöüß][a-z0-9øåæäöüß]*)*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("No-idea,if-is-what,you-want\n"
"No-idea,if-is-whatyou-want\n"
"No-idea,if-is-whatyou-\n"
"No-idea,if-is-whatyou,\n"
"asd,1dsa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")