import re
regex = re.compile(r"(?m)(?<type>@param) *\K(?<scalar>(?![\$])\S+)? *\K(?<var>\$\S+) *\K(?<message>\S+.*\S+)", flags=re.MULTILINE)
test_str = ("--- Copyright @fmargerit ---\n\n"
"/**\n"
" * First variation with scalar type\n"
" *\n"
" * @param Int $a First parameter to add\n"
" * @param Int $b Second parameter to add \n"
" *\n"
" */\n\n\n"
"/**\n"
" * second variation without scalar type\n"
" *\n"
" * @param $a first text \n"
" * @param $b second text\n"
" * @param $c third text\n"
" * \n"
" */\n\n\n"
"/**\n"
" * Invalid case without message\n"
" *\n"
" * @param Int $a \n"
" *\n"
" */\n\n"
"/**\n"
" * Invalid case : without variable\n"
" *\n"
" * @param Int coucou\n"
" *\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")