$re = '/\b(?:Test1 \(VI|Test2 \(VI\))\b/i';
$str = 'Test2 (VI)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);