$re = '/^5[012][0-9]*$/m';
$str = '50
51
52
13
5147sdfa
502121
526
571';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);