#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\s_]+?\W+"
Local $sString = ""portfolio, derp, founders, mentors, :, ?, %, ,>, , ffib, biff, 1, 12.18.02, 12, 2013, 9874890288, .., ..., ...., , ff, series a, exit, general mailing, fr, , , ,, co founder, pitch_at_palace, ba, _slkdjfl_bf, sdf_jlk, )_(, jim.somedude@blahblah.com, ,dd, -, invites,subscribed,, master, , , , dd invites,subscribed, , , , , , , ff dd" & @CRLF & _
" invites, subscribed, , , , , alumni spring 2012 deck: https: www.dropbox.com s," & @CRLF & _
" i69rpofhfsp9t7c practice 20ignition - 20june " & @CRLF & _
" .2134.pdf 2109, hello-world,helo-, -world, " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"klkjsdf"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")