using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<position>top|left)\s*\:\s*(?P<value>[\d]+(?:\.[\d]+)?)(?P<measure>px|%|em|pt);?";
string input = @"position: absolute; cursor: pointer; width: 20px; height: 20px; left: 995.503px; top: 297.366px;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}