package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<position>top|left)\s*\:\s*(?P<value>[\d]+(?:\.[\d]+)?)(?P<measure>px|%|em|pt);?`)
var str = `position: absolute; cursor: pointer; width: 20px; height: 20px; left: 995.503px; top: 297.366px;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}