use strict;
my $str = 'position: absolute; cursor: pointer; width: 20px; height: 20px; left: 995.503px; top: 297.366px;';
my $regex = qr/(?P<position>top|left)\s*\:\s*(?P<value>[\d]+(?:\.[\d]+)?)(?P<measure>px|%|em|pt);?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}