re = /[\w\s]+>(\d{1,2})</
str = '818y1873+130I have some text here09 124i10029102lsdgn2in3>31<
mkm1ikm12klni12m4j12??=?!=I"=and then some text heremsiJR310>39<0MK)==!)="!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end