$re = '~this is (?(?=t\w{3})true|false)~m';
$str = 'this is true
this is false
this is something else
is this true
is this false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);