# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\\/\\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);/{{$1}}/gms;t' <<< "// start file
var nameVar1 = '';
// var nameVar1 = '';
var otherVar1= \"test1\";
var nameVar2 =\"test2\",
otherVar2 = 'test3';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: 'test'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file"