import Foundation
let pattern = #"(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
// start file
var nameVar1 = '';
// var nameVar1 = '';
var otherVar1= "test1";
var nameVar2 ="test2",
otherVar2 = 'test3';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: 'test'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{$1}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)