$re = '/(\$\d+(?:\.\d+)?)[\s\S]*/';
$str = '5 Easy Payments $94.00 $99.00 (176)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);