$re = '/^(foo|bar)\s((?:[a-zA-Z0-9\'.-]{1,7}\s){1,5}\w{1,7}\s?)(?<![\'.-])$/i';
$str = 'bar Brian M. O\'\'Dan Darwin';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);